Конфигуриране на MikroTik като NGFW – интелигентна защитна стена

СЪДЪРЖАНИЕ: Основни правила в защитната стена (base firewall) Блокиране на насилие и порнография (violence, porn) Блокиране на “злонамерени” IP адреси (malicious, botnet) Блокиране на “опасни сайтове” (malicious, hijacked, ransomware) Блокиране на нежелани реклами (advertisements and tracking) Блокиране на социални мрежи (social media) Блокиране на държави (countries) Филтриране на мейл трафика (spammers) Блокиране на децентрализирана атака […]

MikroTik – oсновна конфигурация на HotSpot

MikroTik Router /interface bridge add fast-forward=no name=bridge1 add fast-forward=no name=bridge2 /ip hotspot user profile set [ find default=yes ] mac-cookie-timeout=1d shared-users=100 add mac-cookie-timeout=1d name=trial rate-limit=5M/5M shared-users=300 transparent-proxy=yes /ip hotspot profile add dns-name=internetportal.bg hotspot-address=192.168.4.1 http-cookie-lifetime=1d login-by=cookie,http-chap,trial name=hsprof1 trial-uptime-limit=1d trial-user-profile=trial /ip pool add name=dhcp_pool0 ranges=192.168.0.2-192.168.3.254 add name=dhcp_pool1 ranges=192.168.4.2-192.168.7.254 /ip dhcp-server add address-pool=dhcp_pool0 disabled=no interface=bridge1 lease-time=1d name=dhcp1 add […]

Достъп до Mikrotik RouterOS чрез mactelnet с Ubuntu Linux

Winbox се емулира в Ubuntu много лесно с Wine, но пък не винаги имаме нужда от него. Според мен малко е известно, че достъп с mactelnet може да се случи директно от терминала – бързо, лесно, удобно. Инсталация на mactelnet: Пускаме mactelnet да сканира за устройства: И ето резулата: Ако искаме да се логнем в […]

OpenVPN linux client (Debian/Ubuntu/Kali) MikroTik OpenVPN server

В поста https://itservice-bg.net/mikrotik-openvpn/ конфигурирах три рутера MikroTik които се намират в три отдалечени офиси един от друг в Интернет. Създадох между тях OpenVPN криптирани тунели за да могат техните LAN мрежи да обменят “фирмената” информация по между си а останалия трафик да преминава през локалния доставчик на Интернет. Освен тунелите трябваше да пипна нещо и […]

MikroTik OpenVPN

Защо OpenVPN ? OpenVPN през последните 10 години набра популярност поради няколко причини, първата е, че е отворен код, което значи, че са го прегледали много очи за дупки в сигурноста което създава доверие. Втората е, че се поддържа за всякакви операционни системи (не мисля да ги изброявам защото на практика са всички ползващи се). […]

IPv6 in MikroTik

/ipv6 address add address=2001:470:20f1:2::1 interface=bridge1 add address=2001:470:20f1:1::2 advertise=no interface=ether1   /ipv6 route add distance=1 dst-address=2000::/3 gateway=2001:470:20f1:1::1   /ip dns set allow-remote-requests=yes servers=2001:470:20::2,2001:4860:4860::8888/ipv6 address add address=2001:470:20f1:2::1 interface=bridge1 add address=2001:470:20f1:1::2 advertise=no interface=ether1 /ipv6 route add distance=1 dst-address=2000::/3 gateway=2001:470:20f1:1::1 /ip dns set allow-remote-requests=yes servers=2001:470:20::2,2001:4860:4860::8888 ping [:resolv ipv6.google.com]ping [:resolv ipv6.google.com] ping 2a00:1450:4017:802::200eping 2a00:1450:4017:802::200e tool traceroute 2a00:1450:4017:802::200etool traceroute 2a00:1450:4017:802::200e

Traffic-flow колектор за събиране на мрежови данни

Конфигурация на MikroTik Traffic-flow Маршрутизатора MikroTik от който ще събираме данни е с IP адрес 172.16.100.100 a Linux сървъра който ще поеме и подреди даните е с IP адрес 172.16.200.200 [admin@R1] > ip traffic-flow print enabled: yes interfaces: all cache-entries: 512k active-flow-timeout: 30m inactive-flow-timeout: 15s   [admin@R1] > ip traffic-flow target print detail Flags: X […]

Backup скрипт на bash архивиращ Линукс отдалечени машини и рутери Mikrotik

Rsync OpenSSH sshpass Как работи rsync На този етап в Unix системите rsync е най мощният инструмент за архивиране на данни. След тази кратка команда rsync има в буквалния смисъл хиляди опции и варианти за архивиране на данни. Нека започенм с най простия: rsync –delete -az /home/samyil/music/ /home/samyil/backup/rsync –delete -az /home/samyil/music/ /home/samyil/backup/ Всички файлове от […]

MikroTik BGP dynamic routing Full table three Peers

Configuration AS47453 -autonomous system from RIPE NCC /routing bgp instance add as=47453 client-to-client-reflection=no name=itservice router-id=93.155.130.1/routing bgp instance add as=47453 client-to-client-reflection=no name=itservice router-id=93.155.130.1 Advertisements networks /routing bgp network add network=93.155.169.0/24 synchronize=no add network=93.155.130.0/24 synchronize=no add network=93.155.162.0/24 synchronize=no add network=93.155.131.0/24 synchronize=no/routing bgp network add network=93.155.169.0/24 synchronize=no add network=93.155.130.0/24 synchronize=no add network=93.155.162.0/24 synchronize=no add network=93.155.131.0/24 synchronize=no Create BGP […]