MikroTik HotSpot Gateway – обществен достъп на клиенти, използващи безжична или жична мрежова връзка

MikroTik HotSpot Gateway дава възможност за осигуряване на обществен достъп до мрежата на клиенти, използващи безжична или жична мрежова връзка.

hotspot

MikroTik HotSpot Gateway

1. Какво е Hotspot
Голяма част от хората са чували но не знаят какво всъщност е hotspot. MikroTik HotSpot Gateway дава възможност за осигуряване на обществен достъп до мрежата на клиенти, използващи безжична или жична мрежова връзка. Тоест намирането на приложение на MikroTik HotSpot Gateway е в Интернет клубове, Университети, Училища, гари, летища, хотели, питейни заведения, кафенета, паркове или дори временни терминали за достъп до Интернет.

2. Kak работи Hotspot
Като цяло една Hotspot система работи така:
Когато клиент, дали безжично или по LAN се свърже с Hotspot мрежа, DHCP сървъра на Hotspot рутера му адресира един IP адрес. В този момент клиента е с конфигуриран мрежов интерфейс но няма достъп до Интернет защото трябва да се автентикира пред Hotspot рутера. Затова той трябва да отвори един IE, Mozilla Firefox, Google Chrome или какъвто и да е браузер и да напише в адрес бара сайта който иска да отвори. Вместо сайта ще се появи рекламна страничка на фирмата с форма за логин и парола. Въвеждаики потребителското си име и паролата клиента получава достъп до Интернет за определено време (пример 24 часа) или фиксиран обем трафик (пример 20Gb). След автентикацията вашият браузър е приел така наречената бисквитка (cookie) в която е определено времето за следващата автентикация. През това време hotspot системата не би трябвало да иска повторно въвеждане на паролата и страничката с логина не би трябвало да се появява. Дали браузера е отворен или не също няма никакво значение, след като сте се логнали и сте в системата за определения ви период от време или обем трафик трябва да имате пълен достъп до Интернет и всичките ви приложения да работят.

3. Видове Hotspot
Видовете Hotspot аз ги деля на два. Платен и безплатен (временен).

а) Платения вариант в повечето случай е закупуването на ваучер с определено количество трафик като например 5лв за 20Gb. По времето в което сме се логнали ако напишем IP адреса на рутера в wep трябва да видим страничка с информация колко трафик сме изчерпали. След изтичането на тези 20Gb изтича и сесията и така пак се появява страничката с логин-а и достъпа до Интернет е спрян.

б) Безплатен или временен достъп се използва в случайте само когато определени клиенти трябва да имат Интернет. Примери за това много но най пресния ми е – два хотела един до друг. Собственика на единия хотел не иска клинетите на другия да ползват от неговия Нет. По тази причина всеки един клиент получава при настаняването си потребителско име и парола. Без значение къде се намира в хотела дали през Wi-Fi или от LAN розетката в стаята си получава достъп до Интернет.

4. Хардуер
Тъй като примера който ще дам е за Mikrotik рутер ще ни трябва един такъв закачен на отделен порт WAN за доставчик на интернет а останалите портове LAN могат да бъдат свързани с почти всичко – switches, AP, AP-repeater, WDS system и така нататък.

5. Конфигурация
HotSpot Gateway трябва да има най-малко два конфигурирани мрежови интерфейси.

/ip address
add address=93.155.130.10/28 interface=ether1
add address=192.168.100.1/24 interface=ether2
 
/ip route
add dst-address=0.0.0.0/0 gateway=93.155.130.1
 
/ip dns
set allow-remote-requests=yes servers=208.67.220.220,208.67.222.222

HotSpot в MikroTik има удобен “setup” за конфигуриране на рутера в такъв режим.

[admin@hotspot] > ip hotspot setup 
Select interface to run HotSpot on 
 
hotspot interface: ether2
Set HotSpot address for interface 
 
local address of network: 192.168.100.1/24
masquerade network: yes
Set pool for HotSpot addresses 
 
address pool of network: 192.168.100.2-192.168.100.254
Select hotspot SSL certificate 
 
select certificate: none                    
Select SMTP server 
 
ip address of smtp server: 0.0.0.0
Setup DNS configuration 
 
dns servers: 192.168.100.1
DNS name of local hotspot server 
 
dns name: login.itservice-bg.net
Create local hotspot user 
 
name of local hotspot user: user1
password for the user: 1234

След цялата тази операция ако отворим един браузър и напишем в адрес бара му някакъв сайт трябва да ни изкочи тази страница.

hotspot1

След като се логнем ще ни се отвори сайта който сме си пожелали но ако искаме инфорамция за нас от рутера той ще ни я даде на неговата страница http://192.168.100.1 (IP адреса който зададохме на LAN мрежата)

hotspot2

Несъмнено през програмата WinBox ще ни е много по удобно да конфигурираме нашият HotSpot рутер от сега нататък защото имаме по детайлна информация в панела IP = Hotspot. Първото нещо което трябва да направим е да увеличим броя потребителите които могат да влизат от стандартния профил от 1 поне на 100. Разбира се профилите могат да бъдат много и различни видове а в самите профили може да има много и различни потребители (usres)

hotspot3

Тук е важно да се обърне внимание в меню User – добавянето на клиенти и лимитиране по време и трафик

hotspot4

Както се вижда има страшно много опции за финно конфигуриране на MikroTik HotSpot Gateway и е ясно че, покриват и най капризните нужди на администратора.


Въпросната страничка за логин в рутера е просто един обикновен .html код който може лесно да се редактира за нуждите на фирмата. За целта трябва да се влезне в рутера с filezilla клиент през ftp и да се свали директорията hotspot. В нея се намира файла login.html в който единствено трябва да запазим формата за логване.

hotspot-site

login-hotspot

3 comments on “MikroTik HotSpot Gateway – обществен достъп на клиенти, използващи безжична или жична мрежова връзка

  1. Здравейте,

    Може ли да дадете по-подробна информация за IP адресите които сте написали, тъй като аз имам 2 локални мреж (работна и guest) и и не ми става ясно от примера как само на едната мрежа да направя хотспота 🙂 Благодаря Ви предварително за вниманието.

  2. Ако браузърите на компютрите са настроени да изтриват кукитата, при следващите опити за логване микротика пак ли ще иска юзър и парола?

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.