Debian, Kali Linux – nftables Firewall

Нека да разгледаме по долу снимка на екрана от моя лаптоп с Кали Линукс. Видно е, че съм получил и от двата протокола IPv4/IPv6 мрежови адреси, така наречения Dual Stack. В iptables трябва да конфигурирам и двата протокола в различна конфигурация с iptables и ip6tables но с nftables това не е нужно. Отварям конфигурационния файл […]

iptables-persistent Debian/Ubuntu/Kali

В Debian базираните дистрибуции има различни варианти за съхранение и въстановяване на правилата в защитната стена (iptables) след рестарт или след някаква промяна в конфигурацията. Един от удобните начини е чрез скрипта iptables-persistent, нека го инсталираме в командия ред с: Инсталатора ще ни зададе въпрос да създаде ли конфигурационен файл за ipv4 протокола в който […]

Kali Linux замръзване на клавиатурата

Купих си нов лаптоп, инсталирах му Kali Linux, гладка инсталация, всичко си работи, но ?!?! След 20-30 минути забелязах едно досадно заспиване на клавиатурата за няколко секунди през съвсем случаен период. Опитах се да не му обръщам внимание защото от време на време направо изчезва, после за 5 минути може да заспи три пъти за […]

MikroTik – oсновна конфигурация на HotSpot

MikroTik Router /interface bridge add fast-forward=no name=bridge1 add fast-forward=no name=bridge2 /ip hotspot user profile set [ find default=yes ] mac-cookie-timeout=1d shared-users=100 add mac-cookie-timeout=1d name=trial rate-limit=5M/5M shared-users=300 transparent-proxy=yes /ip hotspot profile add dns-name=internetportal.bg hotspot-address=192.168.4.1 http-cookie-lifetime=1d login-by=cookie,http-chap,trial name=hsprof1 trial-uptime-limit=1d trial-user-profile=trial /ip pool add name=dhcp_pool0 ranges=192.168.0.2-192.168.3.254 add name=dhcp_pool1 ranges=192.168.4.2-192.168.7.254 /ip dhcp-server add address-pool=dhcp_pool0 disabled=no interface=bridge1 lease-time=1d name=dhcp1 add […]

Как актуализирах файла с корените DNS сървъри в bind

Файлът на коренната зона на DNS сървърите ми е остарял. Не е коректна информацията защото един сървър наскоро промени своя IP адрес. Как актуализирах файла с данни за root DNS на моите Линукс сървъри? Първо преместих файла: После изтеглих актуалния файл: рестартирах bind

Създаване на скрипт в systemd с Firewall против SPAM от Blocklistde и Spamhaus на Debian 9

Инсталиране на ipset Създавам инициализиращ файл в systemd Поставям в него следното съдържание [Unit] Description=Spam Firewall for Servers DefaultDependencies=no Wants=network-online.target After=network-online.target   [Service] Type=oneshot ExecStart=/etc/init.d/firewall start ExecReload=/etc/init.d/firewall restart ExecStop=/etc/init.d/firewall stop RemainAfterExit=yes   [Install] WantedBy=multi-user.target[Unit] Description=Spam Firewall for Servers DefaultDependencies=no Wants=network-online.target After=network-online.target [Service] Type=oneshot ExecStart=/etc/init.d/firewall start ExecReload=/etc/init.d/firewall restart ExecStop=/etc/init.d/firewall stop RemainAfterExit=yes [Install] WantedBy=multi-user.target След което създавам […]