ipV6

IPv6 – Участвайте в прехода

Internet Protocol (IP) е основния протокол за комуникация в Интернет
Предназначението на IP протокола е да позволи адресация на информацията, която се изпраща по мрежата. На всеки хост в мрежата се дава уникален адрес (наречен IP адрес). В момента се използва версия 4 на протокола, при която IP адресите са 32-битови цели числа и изглеждат така: 93.155.130.14. Недостатък на версия 4 на протокола е, че броят на адресите не достига в световен мащаб. През последните години версия 6 на протокола започва да влиза в масова употреба. IP адресите от версия 6 са 128 битови числа и изглеждат така: 2001:470:20f1:2:48ee:bc44:1df5:b914.

В момента ползвате IPv4 адрес

54.227.127.109

Интернет протокол IPv4 Интернет протокол IPv6
Интернет протокола – версия 4 (IPv4), предоставя приблизително адресно пространство малко над 4 милиарда IP адреса. В началото, изчерпването на адресите в IPv4 не стояло като проблем на дневен ред, тъй като се е предполагало, че тази версия не била предназначена за обществено ползване. Основното предимство на IPv6 пред IPv4 е, че поддържа огромно адресно пространство. Дължината на един IPv6 адрес е 128 бита в сравнение тази при IPv4, която е едва 32 бита. При IPv6 това осигурява над 300 млн IP адреса за всеки един жител на земята или около 340 трилиона IP адреси общо.
Очаква се в следващите няколко години броят на устройствата, свързани към Интернет, изискващи уникален IP адрес да расте лавинообразно. Главната причина за това е интензивното предлагане на пазара на битова електроника на устройства, чиито функционалност е базирана на Интернет комуникационните технологии. Типични представители на тези иновативни потребителски продукти са интелигентните електрически уреди, системните за отдалечено поддържане на дома, системи за контрол на достъпа, системи за видеонаблюдение, системи за мониторинг и много други. Всички изброени могат да се намират в един дом. Масовото използване на тези устроиства ще засилят търсенето на все по-големи количества уникални IP адреси, което, от своя страна, ще направи внедряването на новия адресен протокол — IPv6, неизбежен процес.
Съвместимост на IPv4 с IPv6
Важно е да се знае, че двете версии на IP протокола са несъвместими което пък не пречи те да работят в една и съща физическа среда. Когато даден Интернет сайт поддържа само IPv4, клиент конфигуриран само с IPv6 адрес няма да го достъпи и обратното. Съвремените рутери и клиентски операциони системи обаче поддържат едновременно и двете версии на IP протокола, механизъм който се нарича dual-stack. При едновремено конфигуриране и на двата протокола с предимство се избира достъпът до услугата по IPv6, това приоритизиране става посредствон DNS (системата за имена в Интернет) Ако определена услуга на сървър в интернет е описана в DNS с IPv6 адрес то клиента с dual-stack конфигурация избира нея, ако няма такава – преминава към IPv4 адресация.

dual-stack операциона система Windows


dual-stack операциона система Ubuntu Linux

;
samyil@desktop:~$ ping6 -n -c 4 itservice-bg.net
PING itservice-bg.net(2001:470:20f1::3) 56 data bytes
64 bytes from 2001:470:20f1::3: icmp_seq=1 ttl=62 time=1.36 ms
64 bytes from 2001:470:20f1::3: icmp_seq=2 ttl=62 time=1.60 ms
64 bytes from 2001:470:20f1::3: icmp_seq=3 ttl=62 time=2.89 ms
64 bytes from 2001:470:20f1::3: icmp_seq=4 ttl=62 time=0.845 ms

--- itservice-bg.net ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 0.845/1.677/2.899/0.757 ms
;
;
samyil@desktop:~$ dig @2001:470:20f1::3 AAAA itservice-bg.net

; <<>> DiG 9.10.3-P4-Ubuntu <<>> @2001:470:20f1::3 AAAA itservice-bg.net
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45742
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 5
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;itservice-bg.net.		IN	AAAA

;; ANSWER SECTION:
itservice-bg.net.	86400	IN	AAAA	2001:470:20f1::3

;; AUTHORITY SECTION:
itservice-bg.net.	86400	IN	NS	v6ns1.itservice-bg.net.
itservice-bg.net.	86400	IN	NS	ns2.itservice-bg.net.
itservice-bg.net.	86400	IN	NS	ns1.itservice-bg.net.
itservice-bg.net.	86400	IN	NS	v6ns2.itservice-bg.net.

;; ADDITIONAL SECTION:
ns1.itservice-bg.net.	86400	IN	A	93.155.130.14
ns2.itservice-bg.net.	86400	IN	A	93.155.130.11
v6ns1.itservice-bg.net.	86400	IN	AAAA	2001:470:20f1::2
v6ns2.itservice-bg.net.	86400	IN	AAAA	2001:470:20f1::3

;; Query time: 3 msec
;; SERVER: 2001:470:20f1::3#53(2001:470:20f1::3)
;; WHEN: Wed Feb 22 13:28:40 EET 2017
;; MSG SIZE  rcvd: 237
;
Внедряване на IPv6
Тъй като IPv6 има непреодолими разлики с IPv4, функционирането на двата протокола едновременно обикновенно се осъществява по два начина – чиста Ethernet свързаност или с тунелен протокол, носещ в него IPv6 пакети ползващ за транспорт IPv4 маршрут (6to4 tunnel). Всички съвремени рутери с изключение на ниския клас поддържат 6to4 tunnel така, че вероятноста да се предостави такава свързаност е практически почти навсякъде.

Примерна конфигурация на клиент с домашен рутер MikroTik с 6to4 tunnel работещ в dual-stack режим свързан с граничен маршрутизатор на Айтисървис 2009 ЕООД

/ip dns
set allow-remote-requests=yes servers=2001:4860:4860::8888,2001:4860:4860::4444
 
/interface 6to4
add local-address=93.155.162.48 mtu=1280 name=6to4-tunnel1 remote-address=93.155.130.9
 
/ipv6 address
add address=2001:470:20f1:1::2 advertise=no interface=6to4-tunnel1
add address=2001:470:20f1:2::1 interface=bridge1
 
/ipv6 firewall filter
add action=drop chain=input dst-port=53 in-interface=6to4-tunnel1 protocol=udp
add action=drop chain=input dst-port=2000 in-interface=6to4-tunnel1 protocol=tcp
add action=drop chain=input dst-port=2222 in-interface=6to4-tunnel1 protocol=tcp
 
/ipv6 nd
set [ find default=yes ] advertise-dns=yes
 
/ipv6 route
add dst-address=2000::/3 gateway=2001:470:20f1:1::1


Приставка в браузера Chrome показваща посетения сайт с IPv4 или IPv6 IP адрес е.


Ако проявявате интерес към услугата, свържете се с нас, безплатно е !!!


Още информация за IPv6

Синтаксис на адреси в IPv6
IPv6 адресите са 128 битови и се записват с осем 4-цифрени (16-битови) шестнадесетични числа, разделени с двоеточия. Когато има поредни нули, те могат да не се записват, така че 2001:0470:20f1:0002:0000:0000:0000:0001/64 който е адрес в домашния ми рутер, съм го вдигнал като 2001:470:20f1:2::1/64. Обърнете внимание на двете двоеточия едно до друго. Този начин на съкращаване е доста удобен в случай, че трябва да си запишете или издиктувате IP адреса, както и размера който изглежда е по четим и по малко плашещ.
Глобални IPv6 адреси в Интернет
Глобалните уникални IPv6 адреси се състоят от две части: 64-битова маршрутизираща част [2001:0470:20f1:0002], следвана от 64-битов идентификатор на хоста [0000:0000:0000:0001] респективно маска /64. Прието е, че в Интернет не може да се обявява мрежа с по голяма маска от :/64 (по малък стек от адреси), както е прието също, че е съвсем нормално краен клиент да получи такава мрежа в която на практика има 18446744073709551616 броя IPv6 адреса. Нека се опитам да поясня по добре маршрутизацията на IPv6, като доставчик на Интернет Core Router-а ни обявява IPv6 мрежа 2001:470:20f1::/48 в която има 65536 броя IPv6 мрежи с префикс :/64 като на домашния ми рутер предназначени за клиенти.
Локални IPv6 адреси у дома
На практика, ако на рутера или хоста ви е активиран IPv6 протокола без да сте конфигурирали нищо, на всеки мрежов интерефейс автоматично ще получите локален IPv6 адрес подобен на този fe80::4e5e:cff:fe46:b9fd/64 като в повечето случай последните символи са подобни на MAC адреса на интерфейса. Тези локални адреси винаги започват с fe80, като всъщност fe80::/64 е мрежа от локални адреси, еквивалентна на 169.254.0.0/16 от IPv4. Маршрутизаторите не рутират тези адреси в Интернет, защото те са уникални само в рамките на локалната мрежа.

Малка пояснителна табличка за адресацията в IPv6 протокола:

IPv6 address Prefix length (bits) Description Notes
:: 128 unspecified Used for default route and router solicitations. cf. 0.0.0.0 in IPv4
::1 128 loopback address cf. 127.0.0.1 in IPv4
::ffff:a.b.c.d 96 IPv4 mapped IPv6 address The lower 32 bits are the IPv4 address. Used in socket API’s to represent IPv4 hosts.
fe80:: 10 link-local Unroutable autoconfigured addresses used on a LAN, e.g. for DHCPv6
fc00:: 7 unique local Addresses used only within an autonomous system, unroutable globally. Cf. RFC 1918 addresses such as used in NAT.
ff00:: 8 multicast multicast
2000:: 3 global unicast All global unicast addresses currently begin with 2.

Leave a Reply

Your email address will not be published. Required fields are marked *