Vyatta in big office – VLAN, DHCP, QOS,routing, firewall, webproxy, pptp server and more …

Vyatta in big office – VLAN, DHCP, QOS,routing, firewall, webproxy, pptp server and more …

Преди време показах как конфигурирах Vyatta за малък офис но се мина известно време и се наложи да го направя за доста по голям. Тъй като конфигурацията е доста по сложна а и всеки който е стигнал до тук няма нужда от много обяснения мисля, че само схемата и командия ред ще са достатъчни за да се добие представа как е настроен да работи рутера.

set firewall group address-group proxy-a address 10.125.3.2
 
set firewall group network-group proxy-n network 213.226.63.0/24
set firewall group network-group proxy-n network 10.0.0.0/8
set firewall group network-group proxy-n network 93.155.130.0/23
set firewall group network-group proxy-n network 93.155.162.0/24
set firewall group network-group proxy-n network 93.155.169.0/24
 
set firewall name eth0.523.local default-action accept
set firewall name eth0.523.local rule 1 action accept
set firewall name eth0.523.local rule 1 destination port 8080
set firewall name eth0.523.local rule 1 protocol tcp
set firewall name eth0.523.local rule 1 source group address-group proxy-a
 
set firewall name eth0.523.local rule 2 action accept
set firewall name eth0.523.local rule 2 destination port 8080
set firewall name eth0.523.local rule 2 protocol tcp
set firewall name eth0.523.local rule 2 source group network-group proxy-n
 
set firewall name eth0.523.local rule 3 action drop
set firewall name eth0.523.local rule 3 destination port 8080
set firewall name eth0.523.local rule 3 protocol tcp
 
set interfaces ethernet eth0 description Optisprint
set interfaces ethernet eth0 vif 523 address 93.155.131.20/29
set interfaces ethernet eth0 vif 523 address 194.141.68.30/27
set interfaces ethernet eth0 vif 523 firewall local name eth0.523.local
 
set interfaces ethernet eth1 address 192.168.10.2/24
set interfaces ethernet eth1 description Vivacom
 
set interfaces ethernet eth2 address 172.16.50.1/24
set interfaces ethernet eth2 description Office
set interfaces ethernet eth2 traffic-policy in shaper-out
set interfaces ethernet eth2 traffic-policy out shaper-in
 
set interfaces tunnel tun1 address 172.16.51.2/30
set interfaces tunnel tun1 description Shipka
set interfaces tunnel tun1 encapsulation gre
set interfaces tunnel tun1 local-ip 93.155.131.20
set interfaces tunnel tun1 remote-ip 10.129.3.7
 
set protocols static route 0.0.0.0/0 next-hop 93.155.131.17
set protocols static route 0.0.0.0/0 next-hop 192.168.10.1 distance 2
set protocols static route 10.0.0.0/8 next-hop 93.155.131.17
set protocols static route 62.73.64.0/18 next-hop 192.168.10.1
set protocols static route 62.176.64.0/22 next-hop 192.168.10.1
set protocols static route 77.85.0.0/16 next-hop 192.168.10.1
set protocols static route 79.100.0.0/16 next-hop 192.168.10.1
set protocols static route 82.137.64.0/24 next-hop 192.168.10.1
set protocols static route 83.228.0.0/20 next-hop 192.168.10.1
set protocols static route 85.130.0.0/17 next-hop 192.168.10.1
set protocols static route 87.126.0.0/16 next-hop 192.168.10.1
set protocols static route 89.215.0.0/16 next-hop 192.168.10.1
set protocols static route 90.154.128.0/17 next-hop 192.168.10.1
set protocols static route 95.42.0.0/15 next-hop 192.168.10.1
set protocols static route 192.168.122.0/24 next-hop 172.16.51.1
set protocols static route 192.168.123.0/24 next-hop 172.16.51.1
set protocols static route 192.168.124.0/24 next-hop 172.16.51.1
set protocols static route 192.168.125.0/24 next-hop 172.16.51.1
set protocols static route 192.168.126.0/24 next-hop 172.16.51.1
set protocols static route 194.141.0.0/16 next-hop 194.141.68.1
set protocols static route 212.5.128.0/19 next-hop 192.168.10.1
set protocols static route 212.39.64.0/19 next-hop 192.168.10.1
set protocols static route 212.233.128.19/32 next-hop 172.16.51.1
set protocols static route 212.233.233.65/32 next-hop 172.16.51.1
set protocols static route 213.16.32.0/19 next-hop 192.168.10.1
set protocols static route 213.91.128.0/17 next-hop 192.168.10.1
set protocols static route 213.240.224.0/19 next-hop 192.168.10.1
set protocols static route 217.9.224.0/20 next-hop 192.168.10.1
 
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 default-router 172.16.50.1
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 dns-server 172.16.50.1
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 domain-name itservice-bg.net
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 lease 86400
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 start 172.16.50.51 stop 172.16.50.254
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 static-mapping desktop ip-address 172.16.50.51
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 static-mapping desktop mac-address 00:30:6e:b1:07:4f
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 static-mapping sami-lan ip-address 172.16.50.53
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 static-mapping sami-lan mac-address f0:4d:a2:86:ef:70
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 static-mapping sami-wifi ip-address 172.16.50.52
set service dhcp-server shared-network-name office subnet 172.16.50.0/24 static-mapping sami-wifi mac-address 00:22:fb:5d:21:8e
 
set service dns forwarding cache-size 150
set service dns forwarding listen-on eth2
set service dns forwarding system
 
set service nat rule 1 inside-address
set service nat rule 1 outbound-interface eth1
set service nat rule 1 outside-address address 192.168.10.2
set service nat rule 1 source address 172.16.50.0/24
set service nat rule 1 type source
 
set service nat rule 2 outbound-interface eth0.523
set service nat rule 2 outside-address address 93.155.131.20
set service nat rule 2 source address 172.16.50.0/24
set service nat rule 2 type source
 
set service nat rule 3 destination address 93.155.131.20
set service nat rule 3 destination port 3389
set service nat rule 3 inbound-interface eth0.523
set service nat rule 3 inside-address address 172.16.50.51
set service nat rule 3 inside-address port 3389
set service nat rule 3 protocol tcp
set service nat rule 3 type destination
 
set service snmp community public authorization ro
set service snmp contact support@itservice-bg.net
set service snmp location Bulgaria
 
set service ssh port 22
 
set service webproxy cache-size 100
set service webproxy listen-address 93.155.131.20 port 8080
set service webproxy mem-cache-size 20
 
set system domain-name itservice-bg.net
set system host-name office
 
set system name-server 208.67.220.220
set system name-server 208.67.222.222
 
set system time-zone Europe/Sofia
 
set traffic-policy limiter shaper-out class 51 bandwidth 50mbit
set traffic-policy limiter shaper-out class 51 match user ip source address 172.16.50.51/32
set traffic-policy limiter shaper-out class 52 bandwidth 50mbit
set traffic-policy limiter shaper-out class 52 match user ip source address 172.16.50.52/32
set traffic-policy limiter shaper-out class 53 bandwidth 50mbit
set traffic-policy limiter shaper-out class 53 match user ip source address 172.16.50.53/32
set traffic-policy limiter shaper-out class 54 bandwidth 20mbit
set traffic-policy limiter shaper-out class 54 match user ip source address 172.16.50.54/32
set traffic-policy limiter shaper-out class 55 bandwidth 20mbit
set traffic-policy limiter shaper-out class 55 match user ip source address 172.16.50.55/32
set traffic-policy limiter shaper-out class 56 bandwidth 20mbit
set traffic-policy limiter shaper-out class 56 match user ip source address 172.16.50.56/32
set traffic-policy limiter shaper-out class 57 bandwidth 20mbit
set traffic-policy limiter shaper-out class 57 match user ip source address 172.16.50.57/32
set traffic-policy limiter shaper-out class 58 bandwidth 20mbit
set traffic-policy limiter shaper-out class 58 match user ip source address 172.16.50.58/32
set traffic-policy limiter shaper-out class 59 bandwidth 20mbit
set traffic-policy limiter shaper-out class 59 match user ip source address 172.16.50.59/32
set traffic-policy limiter shaper-out class 60 bandwidth 20mbit
set traffic-policy limiter shaper-out class 60 match user ip source address 172.16.50.60/32
set traffic-policy limiter shaper-out class 61 bandwidth 20mbit
set traffic-policy limiter shaper-out class 61 match user ip source address 172.16.50.61/32
set traffic-policy limiter shaper-out class 62 bandwidth 20mbit
set traffic-policy limiter shaper-out class 62 match user ip source address 172.16.50.62/32
set traffic-policy limiter shaper-out class 63 bandwidth 20mbit
set traffic-policy limiter shaper-out class 63 match user ip source address 172.16.50.63/32
set traffic-policy limiter shaper-out class 64 bandwidth 20mbit
set traffic-policy limiter shaper-out class 64 match user ip source address 172.16.50.64/32
set traffic-policy limiter shaper-out class 65 bandwidth 20mbit
set traffic-policy limiter shaper-out class 65 match user ip source address 172.16.50.65/32
set traffic-policy limiter shaper-out class 66 bandwidth 20mbit
set traffic-policy limiter shaper-out class 66 match user ip source address 172.16.50.66/32
set traffic-policy limiter shaper-out class 67 bandwidth 20mbit
set traffic-policy limiter shaper-out class 67 match user ip source address 172.16.50.67/32
set traffic-policy limiter shaper-out class 68 bandwidth 20mbit
set traffic-policy limiter shaper-out class 68 match user ip source address 172.16.50.68/32
set traffic-policy limiter shaper-out class 69 bandwidth 20mbit
set traffic-policy limiter shaper-out class 69 match user ip source address 172.16.50.69/32
set traffic-policy limiter shaper-out class 70 bandwidth 20mbit
set traffic-policy limiter shaper-out class 70 match user ip source address 172.16.50.70/32
 
set traffic-policy shaper shaper-in class 51 bandwidth 80mbit
set traffic-policy shaper shaper-in class 51 match user ip destination address 172.16.50.51/32
set traffic-policy shaper shaper-in class 52 bandwidth 80mbit
set traffic-policy shaper shaper-in class 52 match user ip destination address 172.16.50.52/32
set traffic-policy shaper shaper-in class 53 bandwidth 80mbit
set traffic-policy shaper shaper-in class 53 match user ip destination address 172.16.50.53/32
set traffic-policy shaper shaper-in class 54 bandwidth 30mbit
set traffic-policy shaper shaper-in class 54 match user ip destination address 172.16.50.54/32
set traffic-policy shaper shaper-in class 55 bandwidth 30mbit
set traffic-policy shaper shaper-in class 55 match user ip destination address 172.16.50.55/32
set traffic-policy shaper shaper-in class 56 bandwidth 30mbit
set traffic-policy shaper shaper-in class 56 match user ip destination address 172.16.50.56/32
set traffic-policy shaper shaper-in class 57 bandwidth 30mbit
set traffic-policy shaper shaper-in class 57 match user ip destination address 172.16.50.57/32
set traffic-policy shaper shaper-in class 58 bandwidth 30mbit
set traffic-policy shaper shaper-in class 58 match user ip destination address 172.16.50.58/32
set traffic-policy shaper shaper-in class 59 bandwidth 30mbit
set traffic-policy shaper shaper-in class 59 match user ip destination address 172.16.50.59/32
set traffic-policy shaper shaper-in class 60 bandwidth 30mbit
set traffic-policy shaper shaper-in class 60 match user ip destination address 172.16.50.60/32
set traffic-policy shaper shaper-in class 61 bandwidth 30mbit
set traffic-policy shaper shaper-in class 61 match user ip destination address 172.16.50.61/32
set traffic-policy shaper shaper-in class 62 bandwidth 30mbit
set traffic-policy shaper shaper-in class 62 match user ip destination address 172.16.50.62/32
set traffic-policy shaper shaper-in class 63 bandwidth 30mbit
set traffic-policy shaper shaper-in class 63 match user ip destination address 172.16.50.63/32
set traffic-policy shaper shaper-in class 64 bandwidth 30mbit
set traffic-policy shaper shaper-in class 64 match user ip destination address 172.16.50.64/32
set traffic-policy shaper shaper-in class 65 bandwidth 30mbit
set traffic-policy shaper shaper-in class 65 match user ip destination address 172.16.50.65/32
set traffic-policy shaper shaper-in class 66 bandwidth 30mbit
set traffic-policy shaper shaper-in class 66 match user ip destination address 172.16.50.66/32
set traffic-policy shaper shaper-in class 67 bandwidth 30mbit
set traffic-policy shaper shaper-in class 67 match user ip destination address 172.16.50.67/32
set traffic-policy shaper shaper-in class 68 bandwidth 30mbit
set traffic-policy shaper shaper-in class 68 match user ip destination address 172.16.50.68/32
set traffic-policy shaper shaper-in class 69 bandwidth 30mbit
set traffic-policy shaper shaper-in class 69 match user ip destination address 172.16.50.69/32
set traffic-policy shaper shaper-in class 70 bandwidth 30mbit
set traffic-policy shaper shaper-in class 70 match user ip destination address 172.16.50.70/32
set traffic-policy shaper shaper-in default bandwidth 10mbit
 
set vpn pptp remote-access authentication local-users username sami password alabala
set vpn pptp remote-access authentication local-users username win2003 password alabala
set vpn pptp remote-access authentication mode local
set vpn pptp remote-access client-ip-pool start 172.16.50.21
set vpn pptp remote-access client-ip-pool stop 172.16.50.50
""
             url http://packages.vyatta.com/vyatta
             username ""
         }
     }
     syslog {
         global {
             facility all {
                 level notice
             }
             facility protocols {
                 level debug
             }
         }
     }
     time-zone Europe/Sofia
 }
 traffic-policy {
     limiter shaper-out {
         class 51 {
             bandwidth 50mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.51/32
                     }
                 }
             }
         }
         class 52 {
             bandwidth 50mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.52/32
                     }
                 }
             }
         }
         class 53 {
             bandwidth 50mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.53/32
                     }
                 }
             }
         }
         class 54 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.54/32
                     }
                 }
             }
         }
         class 55 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.55/32
                     }
                 }
             }
         }
         class 56 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.56/32
                     }
                 }
             }
         }
         class 57 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.57/32
                     }
                 }
             }
         }
         class 58 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.58/32
                     }
                 }
             }
         }
         class 59 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.59/32
                     }
                 }
             }
         }
         class 60 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.60/32
                     }
                 }
             }
         }
         class 61 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.61/32
                     }
                 }
             }
         }
         class 62 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.62/32
                     }
                 }
             }
         }
         class 63 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.63/32
                     }
                 }
             }
         }
         class 64 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.64/32
                     }
                 }
             }
         }
         class 65 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.65/32
                     }
                 }
             }
         }
         class 66 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.66/32
                     }
                 }
             }
         }
         class 67 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.67/32
                     }
                 }
             }
         }
         class 68 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.68/32
                     }
                 }
             }
         }
         class 69 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.69/32
                     }
                 }
             }
         }
         class 70 {
             bandwidth 20mbit
             match user {
                 ip {
                     source {
                         address 172.16.50.70/32
                     }
                 }
             }
         }
     }
     shaper shaper-in {
         class 51 {
             bandwidth 80mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.51/32
                     }
                 }
             }
         }
         class 52 {
             bandwidth 80mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.52/32
                     }
                 }
             }
         }
         class 53 {
             bandwidth 80mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.53/32
                     }
                 }
             }
         }
         class 54 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.54/32
                     }
                 }
             }
         }
         class 55 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.55/32
                     }
                 }
             }
         }
         class 56 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.56/32
                     }
                 }
             }
         }
         class 57 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.57/32
                     }
                 }
             }
         }
         class 58 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.58/32
                     }
                 }
             }
         }
         class 59 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.59/32
                     }
                 }
             }
         }
         class 60 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.60/32
                     }
                 }
             }
         }
         class 61 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.61/32
                     }
                 }
             }
         }
         class 62 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.62/32
                     }
                 }
             }
         }
         class 63 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.63/32
                     }
                 }
             }
         }
         class 64 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.64/32
                     }
                 }
             }
         }
         class 65 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.65/32
                     }
                 }
             }
         }
         class 66 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.66/32
                     }
                 }
             }
         }
         class 67 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.67/32
                     }
                 }
             }
         }
         class 68 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.68/32
                     }
                 }
             }
         }
         class 69 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.69/32
                     }
                 }
             }
         }
         class 70 {
             bandwidth 30mbit
             match user {
                 ip {
                     destination {
                         address 172.16.50.70/32
                     }
                 }
             }
         }
         default {
             bandwidth 10mbit
         }
     }
 }
 vpn {
     pptp {
         remote-access {
             authentication {
                 local-users {
                     username sami {
                         password alabala
                     }
                     username win2003 {
                         password alabala
                     }
                 }
                 mode local
             }
             client-ip-pool {
                 start 172.16.50.21
                 stop 172.16.50.50
             }
         }
     }
 }
[edit]
vyatta@office# run show arp    
Address                  HWtype  HWaddress           Flags Mask            Iface
172.16.50.127                    (incomplete)                              eth2
172.16.50.133            ether   1c:6f:65:32:d9:7f   C                     eth2
192.168.10.1             ether   00:1e:4c:12:f0:47   C                     eth1
172.16.50.52                     (incomplete)                              eth2
93.155.131.17            ether   00:15:17:96:77:62   C                     eth0.523
172.16.50.149                    (incomplete)                              eth2
[edit]
vyatta@office# run show interfaces 
Interface    IP Address         State       Link   Description                  
eth0         -                  up          up     Optisprint                   
eth0.523     93.155.131.20/29   up          up                                  
eth0.523     194.141.68.30/27   up          up                                  
eth1         192.168.10.2/24    up          up     Vivacom                      
eth2         172.16.50.1/24     up          up     Office                       
gre0         -                  admin down  down                                
lo           127.0.0.1/8        up          up                                  
lo           ::1/128            up          up                                  
tun1         172.16.51.2/30     up          up     Shipka                       
[edit]
vyatta@office# run show nat rules
 
Type Codes:  SRC - source, DST - destination, MASQ - masquerade
              X at the front of rule implies rule is excluded
 
rule   type  intf     translation                                               
----   ----  ----     -----------                                               
1      SRC   eth1     saddr 172.16.50.0/24 to 192.168.10.2                      
    proto-all         sport ANY                                                     
 
2      SRC   eth0.523  saddr 172.16.50.0/24 to 93.155.131.20                     
    proto-all         sport ANY                                                     
 
3      DST   eth0.523  daddr 93.155.131.20 to 172.16.50.51                       
    proto-tcp         dport 3389 to 3389                                            
 
[edit]
vyatta@office# run show firewall 
--------------------------------------------------------------------------------
IPv4 Firewall "eth0.523.local":
 
 Active on (eth0.523,LOCAL)
 
rule  action   proto     packets  bytes                                   
----  ------   -----     -------  -----                                   
1     accept   tcp       0        0                                       
  condition - match-SRC-ADDR-GROUP proxy-a tcp dpt:http-alt                     
 
2     accept   tcp       3498     456988                                  
  condition - match-SRC-NTWRK-GROUP proxy-n tcp dpt:http-alt                    
 
3     drop     tcp       61876    5595589                                 
  condition - tcp dpt:http-alt                                                  
 
10000 accept   all       99743    16455027                                
 
[edit]
vyatta@office# run show firewall group       
Name       : proxy-a
Type       : address
References : eth0.523.local-1-source
Members    :
             10.125.3.2
 
Name       : proxy-n
Type       : network
References : eth0.523.local-2-source
Members    :
             10.0.0.0/8
             93.155.130.0/23
             93.155.162.0/24
             93.155.169.0/24
             213.226.63.0/24
 
[edit]
vyatta@office# run show dns forwarding statistics  
----------------
Cache statistics
----------------
Cache size: 150
Queries forwarded: 181272
Queries answered locally: 15225
Total DNS entries inserted into cache: 310247
DNS entries removed from cache before expiry: 80449
 
---------------------
Nameserver statistics
---------------------
Server: 208.67.220.220
Queries sent: 138390
Queries retried or failed: 10297
 
Server: 208.67.222.222
Queries sent: 113546
Queries retried or failed: 7534
 
[edit]
vyatta@office# run show hardware cpu 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 5
model name      : Pentium II (Deschutes)
stepping        : 2
cpu MHz         : 348.209
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pse36 mmx fxsr up
bogomips        : 696.41
clflush size    : 32
cache_alignment : 32
address sizes   : 36 bits physical, 32 bits virtual
power management:
 
[edit]
vyatta@office# run show hardware pci 
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 02)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 02)
00:0a.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 05)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0e.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 08)
00:14.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:14.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:14.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:14.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)
[edit]
vyatta@office# run show hardware dmi 
bios_date: 06/30/98
bios_vendor: Compaq
bios_version: 686T5
board_asset_tag: 
board_name: 042Ch
board_vendor: Compaq
board_version: 
chassis_asset_tag:         
chassis_type: 3
chassis_vendor: Compaq
chassis_version: 
product_name: Deskpro EN Series SFF
product_version: 
sys_vendor: Compaq
[edit]
vyatta@office# run show version 
Version:      VC6.2-2011.02.09
Description:  Vyatta Core 6.2 2011.02.09
Copyright:    2006-2011 Vyatta, Inc.
Built by:     autobuild@vyatta.com
Built on:     Wed Feb  9 20:04:26 UTC 2011
Build ID:     1102092009-7353197
Boot via:     disk
Uptime:       22:25:29 up 34 days,  8:38,  1 user,  load average: 0.00, 0.04, 0.04

Vyatta in big office – VLAN, DHCP, QOS,routing, firewall, webproxy, pptp server and more …

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.